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1. Download QGIS 

To download and install QGIS, go here: https://www.qgis.org/en/site/forusers/download.html 

For those new to QGIS, they recommend the standalone installers. The most stable option is the 

long term release. This guide is based on QGIS version 3.22 long term release. 
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2. Starting a Project 

When you open QGIS, you can start a new project or open a recent one from the Project tab along 

the top menu. To create a new one, go to Project => New and a blank map will open with default 

map properties and settings. 

Save the project by going to Project => Save or with the save button just below the Project tab. 

2.1.  Map properties 

Project (along top menu) => Properties 

- General: Define map units for distance/area measurements and coordinate display 
 

- Metadata: Project description; useful when sharing project 
 

- CRS: Define map coordinate system (CRS); automatically assumes the CRS of the 1st 

layer added to the map, whether or not it was manually set before adding the 1st layer 
 

- Default Styles: Define default symbology 
 

2.2.  Toolbars and panels 

View (along top menu) => Toolbars 

- Allows easier access to tools above map 
 

Project Toolbar 

 

Map Navigation Toolbar 

 

Selection Toolbar 

 

Attributes Toolbar 

 

Digitizing Toolbar 

 

View (along top menu) => Panels 

- Allows easier access to other tools 

- Recommend having the Processing 

Toolbox Panel available to easily access  

and search for tools (shown to right; not 

all tools shown) 
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2.3.  Plugins 

Some tools may not be automatically available/visible. For example, if the Processing tools 

are initially unavailable, the Processing plugin needs to be added. To add plugins, go to 

Plugins (along the top menu) and select Manage and Install Plugins. This takes you to the 

following menu to select and install or uninstall plugins: 
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3. Adding Data 

To add a data layer, go to Layer (along the top menu) and select Add Layer. From there, you can 

select what type of data you are adding (e.g., vector, raster). 

3.1.  Layer properties 

Information: Layer name, data type, coordinate system, fields 

Source: Includes Assigned Coordinate System *Note: changing this does not reproject the 

data; see 3.2 below for how to change the projection for a layer 

Symbology: Settings for layer symbol design 

Labels: Settings for layer labeling 

Auxiliary Storage: Stores information that only belongs to the project; information is not 

saved in the data sources itself (e.g., label information such as position, rotation, size) 

Rendering: Define how the layer appears on the map (not symbology); allows scale 

dependent visibility (changes what layers are visible based on the map scale) 

Metadata: Details about the layer; useful if sharing layer 

3.2.  Reproject vector data 

Vector (along top menu) => Data Management Tools => Reproject Layer 

- Input Layer: the layer to be 

reprojected 
 

- Target CRS: the coordinate 

system you want the layer 

to be 
 

- Reprojected: the original 

layer and new reprojected 

layer will be saved as two 

separate layers; this is 

where you name and save 

the new reprojected layer; 

the small box to the right of 

this allows you to choose 

how this layer is saved 

 

3.3.  Other vector and raster tools 

All other vector and raster tools are located under their respective tabs along the top menu. 

Tools can also be searched for in the Processing Toolbox Panel. Upon opening any tool, there 

should be a description of how the tool works and what data is required or optional. See the 

full QGIS manuals (linked at top) for a more detailed discussion of additional tools. 
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4. Attribute Table 

Open the attribute table by right clicking the chosen layer and selecting Open Attribute Table. 

4.1.  Organization   

This button opens a table similar to the one 

shown to the right. 

Checked fields are shown in the attribute table. 

Fields can also be re-ordered by clicking and 

dragging any field above or below the others. 

4.2.  Filtering data  

Data can be filtered from the attribute table 

menu or the map layers menu. 

From the attribute table, a form is used to filter 

the data based on entered values: 

From the map layers menu, right click the layer to be filtered and select Filter. This will open 

the following form, which requires an expression to filter data: 
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4.3.  Field Calculator 

The field calculator creates and updates fields in the attribute table based on the expression 

entered. Expressions follow a programming language-like syntax. Functions, variables, and 

other values are provided in the center drop down menu. Clicking on any function brings up a 

description, including input parameters. Double-clicking adds the function to the expression. 

A preview of the output is also given in the bottom left corner. 

 

Fields can be created without an expression to update 

values by 

(1) entering edit mode by clicking the pencil icon 

in the top left corner of the attribute table and 

(2) selecting the New Field icon:  

 

 

Fields may also be deleted in edit mode by selecting the Delete Field icon:  
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5. Creating and Editing Shapefile Layers 

5.1.  Creating a new shapefile layer 
 

To create a new layer, go to Layer (top menu) => Create Layer => New Shapefile Layer. 

A form is brought up, which allows you to name the layer, choose the type of features 

(points, lines, or polygons), and add any new fields to the attribute table (these can be edited 

later according to section 4 above). 

5.2.  Snapping options 
 

Before editing features, check the snapping options. Snapping allows you to add or connect 

features to existing features (e.g., connect lines at a line endpoint or at vertices). This is 

especially useful for ensuring that spatial relationships between features are maintained 

(topology). 

Snapping settings are found by going to Project (along the top menu) and selecting Snapping 

Options. This brings up a form similar to the one shown below, which allows you to choose 

which layers have active snapping settings and the type of snapping allowed. 

For a more detailed discussion on the types of snapping available, see the QGIS User Manual 

page on snapping. 

5.3.  Digitization tools 
 

Once you have created a shapefile layer, or if you have a pre-existing one, you can edit the 

layer points, lines, or polygons using the Digitizing Toolbar: 

 

All icons in this toolbar will likely start grayed out, unable to be used. To enable the tools on 

the digitizing toolbar, click the single pencil icon to allow editing. Other icons will vary 

depending on the type of layer features (points, lines, or polygons; the toolbar above is for 

polygons). One tool allows feature creation, another allows editing of vertices. 

IMPORTANT! The normal project save button does not save layer edits! To save layer 

edits, you must use the save button in the digitizing toolbar, next to the pencil editing icon. 
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6. Symbology 

6.1.  Single symbol editing 
 

Layer symbology can be edited by double clicking a layer to open the Properties panel, then 

selecting Symbology. QGIS will automatically set a default symbology, but it typically needs 

to be changed. A sample symbology tab is shown below: 

 

The default symbology is a Simple Fill. By selecting this 

within the symbology tab, you can change the symbol fill 

and border (called “stroke”). 

For both symbol fill and stroke, the color can be changed 

by going to the drop down next to the current color. You 

may either move the color around the color wheel given or 

enter more specific RGB/html values by selecting Choose 

Color. Another option, Pick Color, allows you to choose a 

color from your current screen (similar to the eyedropper 

option found in PowerPoint). 
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6.2.  Categorized and other symbols 
 

Other symbology options are found in the drop down next to Single Symbol at the top of the 

form. A few of these are Categorized, Graduated, and Rule-based: 

- Categorized symbols allow you to have different symbols based on a chosen attribute. 
 

- Graduated symbols allow a different symbol size (and color) based on a chosen attribute. 
 

- Rule-based symbols allow more control over symbols for different features. This option 

allows you to enter an expression to define what features are grouped for symbols. 
 

6.3.  Layer rendering 
 

Below the symbol fill options is a dropdown labeled Layer Rendering. In this dropdown is an 

option to change the layer opacity. This is most useful when you have multiple symbols for a 

single layer (i.e., when you choose any option other than Single Symbol). Instead of changing 

the opacity for each individual symbol, the setting under Layer Rendering allows you to 

change it for all symbols at once. 

6.4.  Creating your own symbol 
 

Under the symbology tab in layer properties, you can change the symbol type by selecting the 

drop down for Symbol Layer Type. 
 

Using Simple Marker, you can layer simple marker symbols by adding symbols with the 

green plus sign in the upper right corner. 

 

 

 

 

 

 

 

 

 
 

6.5.  Saving and copying layer symbology 
 

Symbology may be copied from one layer to another within a single project and saved to use 

in different projects. 

 

Copying a color from one layer to another is the simplest. First, open the symbology tab for 

the layer you want to copy a color from, then open the color dropdown menu (as described 

and pictured in section 6.1). You will see an option to Copy Color. Select this to copy the 

color. Next, go to the layer you want to copy the color to. When you open the color 

dropdown, there should now be an option to Paste Color. Select this to paste the color you 

copied. 
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If you want to copy more than just the color, you can copy a symbol by right clicking on the 

layer, going to Styles, and selecting Copy Symbol. Similarly, you can paste this symbol into a 

new layer by right clicking, going to Styles, and selecting Paste Symbol. 

 

You can also save an entire symbol. For example, you have a point layer symbolized by red 

triangles and a second point layer with the default symbology. 

To save the red triangle symbol, go to the 

symbology tab for that layer. In the bottom 

right corner, select the Save Symbol button. 

This brings up a dialogue box to give your 

symbol a name (shown at right). Adding a 

tag or checking Add to favorites makes the 

symbol easier to find and use later (I 

recommend at least adding it to favorites). 
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Now that the symbol is saved, you can close this layer’s symbology and go to the layer that 

still has the default symbology. Open its symbology tab. In the middle of this tab is a search 

bar that says Favorites. This shows symbols that have been saved. 

 

You can also find the red triangle by opening the full Style Manager: 

Within the style manager, you can browse symbols by their group (Favorites and Tags) and 

by symbol type (marker, line, fill). 

 

Finally, within Style Manager, there is an option to Import/Export symbols in XML (not 

available for all style items), PNG, and SVG formats. This provides a method of sharing 

symbology with other people. Another method, using a GeoPackage file format, allows 

sharing of layer data as well as symbology. This is discussed below in section 10. 
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7. Labeling 

7.1.  Single label editing 
 

Layer labels can be edited by double clicking a layer to open the Properties panel, then 

selecting Labels. QGIS will automatically set No Labels. 
 

When you begin editing labels, you are prompted to select one of the attribute table fields as a 

primary key. The chosen field should have a unique value for every feature so that label data 

(e.g., position, rotation, color) is stored with the correct feature. 
 

Some of the basic labeling options are shown below: 

 
 

More detailed labeling options are found under the other tabs. Of note are 

- Formatting: Change paragraph alignment and spacing 
 

- Buffer: Adds a buffer around text; able to customize the size of buffer around text; 

especially useful to highlight labels over a background of a similar color 
 

- Shadow: Adds a shadow behind text; able to customize the size and location of shadow 

around text; especially useful to highlight labels over a background of a similar color 

Note: buffer and shadow have similar effects, but different settings; shadow provides 

more detailed adjustments, but is not always necessary 
 

- Callouts: Add callouts (lines from features to labels and/or boxes around labels) 
 

- Placement: Sets general location for all labels on/around the features 
 

- Rendering: Allows scale dependent visibility for labels (e.g., labels for smaller features 

remain invisible until zooming in to the chosen scale) 
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7.2.  Rule-based labels 
 

Similar to rule-based symbology, rule-based labels allow more control over labels for 

different features. This option allows you to enter an expression to define what features are 

grouped for labels. 

*Note: As of QGIS version 3.22.6, rule-based labels may appear to function properly before 

disappearing from the map later. The simplest alternative is manually adding labels from the 

final Layout as textboxes (see section 8.1 below). 

 

7.3.  Editing labels 
 

To edit individual labels, first select the pencil from the digitizing toolbar to enter editing 

mode. You can edit labels with the labeling toolbar tools by selecting the tool and clicking the 

label to edit. 

 
From left to right: 

- Pin/Unpin Labels and Diagrams: Pinned 

labels are fixed to a location on the map, so 

they cannot move on their own (labels are 

initially unpinned) 
 

- Show/Hide Labels and Diagrams: With this 

tool, you can click labels to make them 

visible or invisible 
 

- Move a Labe, Diagram, or Callout: Allows 

you to click and drag labels to new 

locations; when labels are moved, they also 

become pinned to their new location 
 

- Rotate a Label: Allows you to click and 

rotate labels; to rotate with more accuracy, 

open the Change Label Properties tool to 

type in a rotation angle. 
 

- Change Label Properties: Allows more 

accurate adjustments to properties like 

placement (x, y coordinates for labels) and 

rotation; also allows individual label 

changes in font, color, and other basic label 

properties (see sample form to right) 
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8. Layouts 

The layout is used to design the final display for a map product, including additional labels, 

images, map legend, and other features. The layout can be printed directly or exported as a pdf, 

image, or png. 
 

To create a new layout, go to Project => New Print Layout. You will be prompted to give the 

layout a name, then a blank layout will open. 
 

The default layout size is 297 x 210 mm with landscape orientation. This is shown in the Item 

Properties tab, which is found by clicking on the blank layout page. 

To edit the layout size, use the drop-down menu next to Size. You can select a pre-made format 

or select custom to input a unique layout size. Selecting custom also allows you to change the 

default units (mm). 
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8.1.  Layout tools 

The map Toolbox toolbar defaults to be down vertically along the left side of the layout. 

However, you can also click and drag the toolbar to position it horizontally above the layout 

with the other toolbars. The Toolbox toolbar is shown here: 

 

 

(1) Select/Move item 

 

(2) Move item content 

This tool allows you to click and drag a map to adjust what part of the map is shown. 

This is different from moving the map to a new location on the layout; the map location 

does not change, only what part of the map is shown. 

 

Any content added to the layout is 

shown in the Items tab. The first check 

box makes an item visible/invisible. 

The second check box locks and 

unlocks an item for editing 

 

(3) Add Map 

You can select this tool, then click 

and drag over the layout area to 

add a map. To change the scale at 

which the map is displayed, edit 

the Scale found in Main Properties 

(Item Properties tab). 

 

Under Layers, checking Lock 

Layers allows you to freeze the 

map’s appearance based on the 

current symbology. Unchecking 

this allows the map to update with 

any changes to symbology. 
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(4) Add Picture 

Images cannot be copied and pasted into a 

QGIS layout. To add a picture, select this tool 

and click and drag to create an empty picture 

box. You can add a pre-made SVG image or 

change it to a raster image. 

 

To use a raster image, select the drop-down 

arrow and choose how the find the image 

(select file, embed file, or from url). 

 

 

(5) Add Label 

This allows addition of text labels. 
 

(6) Add Legend 
 

(7) Add Scale Bar 
 

(8) Add North Arrow 
 

(9) Add Shape 
 

(10)  Add Node Item 

   Node items include polygons and lines. 

Another useful toolbar is the Actions Toolbar: 

 

 

 

(1) Unlock All Items 

This unlocks all items, allowing them to be edited. 

(2) Group Items 
 

(3) Ungroup Items 

 

8.2.  Exporting a layout 

You can export a layout to share with others electronically by going to Layout (top menu) 

and selecting Export as Image, SVG, or PDF. You can also print a layout by going to Layout 

and selecting Print. 

 

 

2 3 1 



 Back to Top 
18 

9. Useful Tools 

9.1.  Check Validity & Fix Geometry 

When using some vector tools that are based on feature shapes and relationships, you may get 

an “invalid geometry” error (e.g., a polygon overlaps itself). 
 

If you want to know what features have invalid geometries, then use the Check Validity tool 

(Vector => Geometry Tools => Check Validity), which outputs a new shapefile and 

corresponding attribute table listing the reason for any invalid geometries. 
 

To fix invalid geometries, use the Fix Geometry tool (Processing Toolbox => Vector 

Geometry => Fix Geometries), which outputs a new, corrected layer. 
 

9.2.  Centroids 

The centroids tool allows you to create a new point layer, where each point represents the 

center of each input feature. For example, given a polygon shapefile for counties, centroids 

could be used to create a point shapefile layer where each point represents the center of a 

county. 
 

9.3.  Create points layer from table 

The create points layer from table tool (Processing toolbox => Vector Creation => Create 

points layer from table) allows you to create a point shapefile layer from a table (e.g., .dbf, 

.csv, .xlsx). The table must contain a column of x and y coordinates and these columns are 

then specified as part of the tool input. 
 

9.4.  Join Tools 

Join tools copy data from one layer’s attribute table to another. The following tools join data 

by different methods. Each relies on a common attribute between 2 layers, either spatial or 

based on a data field in the attribute table. 
 

Join Attributes by Location 

(Vector => Data Management Tools => Join Attributes by Location) 
 

This tool allows data to be joined based on the spatial 

relationship between 2 layers. 
 

Example 

You want to copy data from a polygon layer to a point layer, 

such as illustrated to the right. The tool input form is shown 

below. 
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Base: This is the layer you are adding data to, the point layer 
 

Join: This is the layer you are copying data from, the polygon layer 
 

Geometric Predicate: This defines what spatial relationship is used to select which 

polygon features are joined to which point features. In this example, selecting “within” 

means that points that are within a polygon are joined to that polygon. Data from the 

green polygon would be copied to the three points within that polygon. Data from the 

blue polygon would be copied to the four points within that polygon. The two points 

outside the polygons would remain unjoined. 
 

Join Type: This indicates whether one feature is joined with one or many features from 

the second layer. In this example, one-to-many is used because each point is related to 

one polygon, and one polygon has many points. One-to-one could be used if each 

polygon only had one point. 
 

The output from this tool includes a new joined layer and may include an unjoinable 

features layer. In the example above, the output joined layer would be a new points layer 

where the attribute table has been extended to include the copied data from the polygon 

layer. The two points outside polygons would be in the unjoinable layer. 
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Join Attributes by Field Value 

(Processing Toolbox => Vector General => Join Attributes by Field Value) 
 

This tool is very similar to the Join Attributes by Location tool. The major difference is 

that the 2 layers being joined are related to each other by a common field in the attribute 

table, instead of by location. This means that the layers being joined have an identical 

field with unique identical values for each feature. These unique values allow data to be 

matched from one layer to the other. 
 

The input form is shown below: 
 

 
 

Input Layer: This is the layer you are adding data to 
 

Input Layer 2: This is the layer you are copying data from 
 

Table Field & Table Field 2: These inputs are the fields that are identical in both layers. 

The field type seen left of the name (e.g. text abc, number 123) must also be identical. 
 

The join type and output options are the same as discussed above for the Join Attributes 

by Location tool. 
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Join by Lines (hub lines) 

(Processing Toolbox => Vector Analysis => Join by Lines (hub line) 

This tool is used to create lines between 2 point layers (identified as the Hub layer & 

Spoke layer inputs in the form below). As with the Join Attributes by Field Value tool, 

this Join by Lines tool relies on a common field in each attribute table (identified by Hub 

ID field & Spoke ID field inputs in the form below). 

 

 
 

One point may connect with a single point, or multiple points. This means one point can 

have multiple lines coming from it. The output is only a new Hub lines layer. 

 

Left: 2 point layers (black circles & orange triangles) 

Right: Point layers with hub lines layer 
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10. Sharing Projects as a GeoPackage 

In this guide, you have seen that you can copy, save, and share layer symbology (section 6), and 

create and share layouts (section 8). However, what if you need to share the data itself? 
 

First, make sure you have the original files saved. You can export a copy to share by right 

clicking on the layer to be shared and selecting Export. Here you will see a couple of options: 

Save Feature As, Save as Layer Definition File, and Save as QGIS Layer Style File. For a 

detailed explanation of the Layer Definition File and QGIS Layer Style File, see this page from 

the QGIS User Manual. Essentially, these two file formats are unique to QGIS, meaning they are 

not immediately compatible with other GIS software, such as ArcGIS Pro. 
 

To see what other file formats are 

available, select Save Feature As 

(shown to right). In this case, the 

options shown are for a vector layer. 
 

Here, I will discuss how to save and 

share layers in a GeoPackage. First, 

this file format is useful because it can 

be used in any GIS software (see 

https://www.geopackage.org/). In 

addition, you reduce the number of 

files being shared, making it easier for 

others to find the layer(s) they need. 

Finally, you can share the data and 

maintain all symbology in the shared 

file. This means that the person you are 

sharing the file with does not have to 

take the time to redo all the symbology 

themselves. Essentially, you are giving 

them the finished map product in a 

format they can continue to edit. 
 

You can save multiple layers within a single GeoPackage. To create the GeoPackage, right click 

on the first layer to be shared and go to Export => Save Feature As and select GeoPackage as the 

format. For file name, navigate to where you want the GeoPackage to be saved and give it a 

name. Next, layer name is the name of the layer you selected (it does not have to be identical). 

Select the appropriate coordinate system (CRS). Under the dropdown to select fields, you may 

choose what attribute table fields to save from the selected layer. You may also select the 

geometry type or leave it as automatic. At the bottom, check whether or not you want to add the 

file to your current project map view. Finally, select OK. Now, you have created a GeoPackage 

and it contains one layer. 
 

To add additional layers to the same GeoPackage, right click the layer, go to Export => Save 

Feature As and select GeoPackage. For file name, navigate to the GeoPackage you just created 

and select it. Fill in the remaining options as necessary, then select OK. Repeat for each layer to 

be shared. Now, only the single GeoPackage file needs to be shared for someone else to have 

access to each layer saved within it. 

https://docs.qgis.org/3.22/en/docs/user_manual/appendices/qgis_file_formats.html
https://www.geopackage.org/

